Комментарии  

-5 #1 tanya 06.09.2016 14:48
Установила Joomla 3.6. В менеджере расширений все плагины включены, но при попытке загрузки новых шаблонов выдает "Предупреждение
JInstaller: :Install: Не удалось найти XML-файл установки" и "Ошибка
Невозможно найти установочный пакет".

Может быть кто-то знает, как решить эту проблему? Заранее спасибо!
Цитировать
-4 #2 Администратор 06.09.2016 15:01
Здравствуйте. Извините, но Вы, как говориться, "не в ту степь попали". Поищите статью в этой же категории с названием "Ошибка загрузки файла...". В ней всё сказано, как решить вашу проблему.
Цитировать
0 #3 Evgeniy 24.09.2016 14:01
На всякий случай тут ответ тоже оставлю.

Найти и установить недостающие плагины через /administrator/index.php?option=com_installer&view=discover
Должно быть 4:
Installer - Install from Web installer webinstaller
Installer - Install from Upload installer packageinstaller
Installer - Install from Folder installer folderinstaller
Installer - Install from URL installer urlinstaller
Цитировать
-1 #4 Игорь 07.10.2016 11:44
Огромное спасибо за подсказку. Хотел уже все сносить и по новому устанавливать.
Цитировать
+3 #5 Виталий 31.10.2016 18:47
Что делать,если плагинов для установки нету? Должно быть 4 - нету ни одного. При нажатии кнопки "поиск" - "Ничего не найдено".
Цитировать
-2 #6 Оксана 04.11.2016 10:43
Такая же ерунда. Обновила джумлу до 3.6.4 и нет ни одного плагина установки расширений.
Цитировать
-4 #7 joomla-developer 14.11.2016 03:09
И у меня не находит эти плагины установок расширений, хотя они должны быть, т.к. я уже перезаписывал файлы CMS из нового установочного архива. Полагаю нужны правки в базе чтобы увидел, только вот где?!
Цитировать
-5 #8 Администратор 16.11.2016 09:50
Какие папки есть у вас по этому пути: /plugins/instal ler/
Цитировать
-5 #9 Oleg Vetrau 16.11.2016 19:26
Цитирую Evgeniy:
На всякий случай тут ответ тоже оставлю.

Найти и установить недостающие плагины через /administrator/index.php?option=com_installer&view=discover
Должно быть 4:
Installer - Install from Web installer webinstaller
Installer - Install from Upload installer packageinstaller
Installer - Install from Folder installer folderinstaller
Installer - Install from URL installer urlinstaller

Все помогло - рекомендую этот способ.
Цитировать
-4 #10 Сергей 17.11.2016 09:20
Он не находит эти installer в поиске хотя в корне папки plugins они есть!
Цитировать
-4 #11 Администратор 17.11.2016 11:02
Создайте бекап сайта и БД.
Проверьте права на папку "tmp" (попробуйте выставить 777) и правильно ли указан путь к ней в "configuration.php".
Если не помогло попробуйте удалить все папки из /plugins/instal ler/ и заново загрузить их из github: https://github.com/joomla/joomla-cms/tree/staging/plugins/installer
Цитировать
-4 #12 Kostya 17.11.2016 15:22
Ну и как я установлю какой-либо плагин-установщ ик через Менеджер расширений, если у меня не работает Менеджер расширений потому, что не установлен плагин-установщ ик?
Звучит как "Если вы больны и от вашей болезни нет лекарства - просто достаньте где-нибудь лекарство от вашей болезни!"
Я правильно понимаю суть этой вашей горе-статьи?...
Цитировать
-5 #13 Администратор 17.11.2016 15:38
Нет, не правильно поняли суть этой статьи!
Цитировать
-5 #14 Марина 26.11.2016 21:58
Плагины все в discover есть. При попытке установить пишет "предупреждение недопустимое расширение" и "сообщение Поиск дистрибутивов завершился с ошибкой: 0". Все файлы в папках присутствуют, перепроверила не один раз и перезалила из разных архивов (обновление и полный пак 3.6).
В какую сторону копать, чтобы избавиться от ошибок и установить-таки эти плагины?
Цитировать
-5 #15 DEV 27.11.2016 21:41
Для меня решение задачи еще актуально!! - НЕ могу найти плагины "Установщик" в менеджере плагинов.
- В папке install есть папки с плагинами (packageinstall er, folderinstaller и urlinstaller);
- пути к logs и tmp указаны верно;
- странно, но в папке temp только один.

Может есть еще идеи куда копать ???

Kostya, помимо прямой загрузки на хостинг можно (я так и сделал) залить полный дистрибутив Джумлы через "Обновление Joomla"
Цитировать
-5 #16 Алексей 09.12.2016 15:07
Очень помогли, спасибо. А то не знал, что уже придумать.
Цитировать
+7 #17 Роман Синицын 10.12.2016 18:43
Благодарим автора за урок...
Цитировать
-5 #18 Дмитрий 18.12.2016 17:15
Тоже были проблемы с установкой joomla 3.6.5 .
Покопался и обнаружил, что отсутствует файл joomla.xml, перенес файл из пакета 3.4.6 и все установилось замечательно. Может кому-то поможет.
Цитировать
-5 #19 ArtyomKAA 20.12.2016 13:16
Долго бился над проблемой... Ситуация была аналогичной Марине и DEV... Но нашел! Админ, можно добавлять в текст.
Идем в PhpMyAdmin. Входим в ***_extensions и там уже вносим кучу изменений:
id/name/client_id/enabled/access/protected/ordering/state
10/com_installer/1/1/1/1/0/0
Внимание! Дальше Важно менять и ID и значения (У меня были id = 0)
455/plg_installer_packageinstaller/0/1/1/1/1/0
456/PLG_INSTALLER_FOLDERINSTALLER/0/1/1/1/2/0
457/PLG_INSTALLER_URLINSTALLER/0/1/1/1/3/0
Также у меня были проблемы с обновлениями joomla. также исправляется там же. УДАЧИ!
Цитировать
-5 #20 Марина 26.12.2016 11:34
Цитирую ArtyomKAA:

455/plg_installer_packageinstaller/0/1/1/1/1/0
456/PLG_INSTALLER_FOLDERINSTALLER/0/1/1/1/2/0
457/PLG_INSTALLER_URLINSTALLER/0/1/1/1/3/0


В базе вообще нет этих строк. Нигде. Даже в предыдущей версии Джумлы, где эти плагины работают...
Может, кто-нибудь может выложить всё содержимое этих строк, чтобы можно было в базу добавить? Может, решит проблему..
А вот с недопустимым расширением непонятно пока что делать.
Цитировать
-5 #21 Алексей 06.01.2017 10:18
Спасибо! Нашел. Пол дня голову ломал.
Цитировать
-5 #22 Марина 09.01.2017 12:28
Совет из 19-го комментария от ArtyomKAA помог! Добавьте в статью, пожалуйста.
Плагины после этого изменения в базе работают как надо. Ещё 3 плагина, которые точно также глючили, починила аналогичным образом.
Подсказка, на случай если эти строки отсутствуют в базе. Во-первых, посмотрите в конце этой таблицы, они все обнулённые толпятся в конце из-за последнего параметра -1, хотя должен стоять 0. Во-вторых, если их нет всё же, ставьте Денвер и на Денвер чистую Джумлу 3.6, лезьте в базу и вручную заводите эти строки с теми же параметрами.
Удачи!
Цитировать
-4 #23 Руслан 21.01.2017 07:27
Всем привет! Кто не может найти эти плагины в поиске (discover), нужно просто в том же discover (поиск) нажать кнопку «Найти» со стрелочкой, которая рядом с кнопкой установить и эти плагины появятся.
Цитировать
-5 #24 Игорь 25.02.2017 02:23
Ребята все не то. Способ с "discover" и прочее не помог. У меня без проблем обновлялась Joomla до 3.5.1. Дальше пошли фокусы, как сделал я:
Скачал с сайта https://downloads.joomla.org/ru/cms/joomla3, Joomla_3.6.0-St able-Update_Pac kage, просто заливаем на хост, копировать, заменить (я делал на локальном хосте, denwer), ни чего не открываем и делаем след. шаг.
Потом скачал Joomla_3.6.x_to _3.6.5-Stable-P atch_Package (Update и Patch - не путайте) залил на хост копированием и заменой.
Зашел в админку, зашел в обновления Joomla, там кнопочка появилась "Переустановить основные файлы Joomla". После этого все стало корректно работать.
Далее (у кого denwer), убрал еще одну ошибку (светиться красным в верху админке - Ошибка... без номера, без ни чего ), в файле usrlocalmysql-5 .*my.ini, поставил sort_buffer_siz e = 256K.
Последовательно сть действий не поддается логике, просто мне помогло, именно, такая последовательно сть действий.
Цитировать
-4 #25 Алексей 15.03.2017 13:37
Спасибо, помогло залить на FTP из архива

plugins/installer

затем проделать процедуру

/administrator/index.php?option=com_installer&view=discover
Цитировать